Warrior NO Combat BuG

Issue: (quick one-line precis of what happened)
In my PVP campaign the Warrior Class in my game seem to have bugged out and cannot go into combat.
Crash (y/n): (did the game crash?)
No
Platform (Windows/Mac/Linux): (what sort of computer were you playing on?)
Windows 10 Pro,
i5 4970k 4.4ghz
Geforce Gtx 1070
Installed on a SSD

Version number: (what version number of the game are you running? If you’re able to reach the ‘desktop’ interface of the game, you can see this information in the ‘About’ window)
2.1.76

Description: (more detailed description of what happened, if you need more space. If whatever happened happens repeatably, please let me know!)

I believe it has something to do with balancing the characters as I was doing that for a while.
Afterwards the warrior class in the game would just stand there and basically die; makes it REALLY hard to balance when one of the classes just stand there like a punching bag.

(please consider attaching your save file, if you think it might help me track down the trouble you’re having!)
I’ve searched my C and D drives as well as documents and program files in both drives.
I cannot seem to find where the save file is located,
will update with save file upon reply.

Hi, Bruce! Check your C:\Users\<Account Name>\AppData\Roaming\VectorStorm\MMORPG Tycoon 2\save\ directory. You’ll find a folder named for your game, which contains your saves. The only file I need is probably “autosave.vrz”, or whatever save shows the problem. I don’t need any of the .meta.vrz files. :slight_smile:

Thanks for reporting, and I’m looking forward to investigating and finding out what’s going wrong!

https://filebin.net/yssp6dwtrg0tj707

The forums do not allow uploading beside pic files.
Cheers trevor!
God Speed.

Thanks for reporting this! You found a fairly important bug in the combat AI that I’ve never seen before!

Your warriors are configured with two combat abilities.

The first one generates some rage, damages the target by 1 point of health, and heals the user for 1 point of health.

The second uses rage and damages the target by 5 points of rage.

The bug was this: The AI code which was evaluating which attack was the best one to use at any given moment wasn’t considering who each effect was being applied to. It just summed up everything. So that first combat ability saw a -1 health effect and a +1 health effect, added them together, and decided that meant that the attack did zero damage, and so didn’t ever bother using it.

And since it didn’t use it, the second ability never had enough rage to be used.

I’ve fixed it now; it no longer considers a “self heal” effect to counteract a “target damage” effect! (There was also the inverse problem when looking for self healing abilities; I’ve fixed that too!)

These fixes will go up in the next build to go on Steam, hopefully within the next few days. For right now, you can work around the issue by removing the self heal part of the first attack (or just making the target damage effect a bit stronger than the self healing effect)

Thanks again for reporting it and providing the save file so that I could debug what was going wrong!

Interesting, coding is a finicky thing.

One more thing I forgot to mention; the scout class or basically anyone with missile range can outrun whoever is chasing them indefinitely.
Lets just say the ranged character no matter how I tried to balance it seems to just run before the other character can reach them.
Monsters will chase and land almost 0 hits sometimes.

I’ve tried to slow down the ranged unit and increase the speed of melee units.
All to no success.

So the melee character gets right up to the ranged and kind of stares at the missile character; missile character shoots, runs back and repeats receiving little or sometimes no damage at all from the melee character.

Keep up the great work trevor!
This game seems to have lots of potential.
Cheers.