New game loads forever and never starts

Hello friends,

I am trying to play this amazing looking game. But when i reach the main menu and start a new game I can’t load it. I know my hardware (a laptop) supports open GL up to 4.0 (higher then the required 3.3) but i think there is still an error there. I included the log below. I tested it both in the test version and the current patch. Yesterday I waited for a full hour and it still didn’t start.

Hopefully someone can help me.

Simonde2

win64
0.17.247-g83a5eb5
Checking supported resolutions...
Available Modes
0: 1366 x 768
1: 1024 x 768
2: 800 x 600
3: 640 x 480
Init: Initialising fullscreen window
Width before: 1366
Found 2 displays:
Display #0 Generic PnP Monitor (1366x768)
Display #1 Generic PnP Monitor (1280x1024)
videoFlag added: Fullscreen Desktop
SDL_CreateWindow 1366x768x32 video mode, flags 4099
OpenGL Context:
Vendor: Intel
Renderer: Intel(R) HD Graphics 4000
Version: 3.3.0 - Build 10.18.10.4425
GLEW: 1.11.0
Shading Language Version: 3.30 - Build 10.18.10.4425
== Begin OpenGL limits ==
Max 3D texture size: 2048
Max array texture layers: 2048
Max clip distances: 8
Max samples in a color multisample texture: 8
Maximum atomic counters: 4096
Maximum fragment shader uniform components: 233472
Maximum geometry shader uniform components: 233472
Maximum combined texture image units: 96
Maximum combined uniform blocks: 70
Maximum cube map dimensions: 16384
Maximum samples in a multisample depth or depth-stencil texture: 8
Maximum simultaneous draw buffers: 8
Maximum simultaneous draw buffers with dual-source blending: 1
Recommended maximum number of vertex array indices: 1048576
Recommended maximum number of vertex array vertices: 1048576
Max fragment shader input components: 128
Max fragment shader uniform components: 4096
Maximum texels in the texel array of a texture buffer: 134217728
Maximum supported texture image units in a fragment shader: 16
Maximum texture size (rough estimate): 16384
Maximum uniform buffer binding points: 70
Maximum uniform block size: 65536
Maximum uniform locations: 65536
Maximum varying components: 64
Maximum floating point varying components: 64
Maximum atomic counters in vertex shaders: 0
Maximum vertex attributes in vertex shader: 16
Maximum active shader storage blocks in a vertex shader: 16
Maximum texture image units in vertex shader: 16
Maximum uniform components in vertex shader: 4096
Maximum output components in vertex shader: 128
Maximum uniform blocks per vertex shader: 14
Maximum simultaneous viewports: 16
Maximum MSAA samples: 8
NVidia-only: Currently available video memory: 8
ATI-only: Currently available video memory: 8
== End OpenGL limits ==
anisotropic texture filters: SUPPORTED
DOUBLE-BUFFERED
VSync: DISABLED
TextureUnits: 16 from vertex shader, 96 total
Hinted minimise on focus loss: FALSE (as there are 2 monitors)
Display refresh rate: 60
Width after: 1366
Screen Ratio: 1.778646
CPU: Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz
Number of hardware cores: 4
System RAM: 7.87 gb
-- Initialising game "MMORPG"
TextInput was enabled by default; turning it off until we need it!
SizeChanged EVENT: 1366, 768
Requesting FMOD version: 2.0.7
Got FMOD version: 2.0.7
StudioSystemCreate succeeded
Number of audio drivers: 2
Default audio driver is: 0 (Luidsprekers (2- USB Audio Device))
Audio device 0: "Luidsprekers (2- USB Audio Device)" SystemRate 48000, SpeakerMode "stereo", SpeakerChannels 2
Audio device 1: "Luidsprekers (High Definition Audio Device)" SystemRate 48000, SpeakerMode "stereo", SpeakerChannels 2
Done enumerating audio drivers
StudioSystemInit succeeded
STEAM: Branch: default
STEAM: Found 0 Steam controllers!
STEAM: IsSubscribed: TRUE
STEAM: IsSubscribedFromFreeWeekend: FALSE
STEAM: IsLowViolence: FALSE
STEAM: IsCybercafe: FALSE
STEAM: IsVACBanned: FALSE
STEAM: CurrentGameLanguage: english
STEAM: PhoneVerified: TRUE
STEAM: TwoFactorEnabled: FALSE
STEAM: SteamLevel: 9
Icon Set 'Attack icons': Found 340 images
Icon Set 'Heal icons': Found 31 images
Icon Set 'Buff icons': Found 129 images
Icon Set 'Debuff icons': Found 84 images
Icon Set 'Misc icons': Found 0 images
Icon Set 'Desktop Icons': Found 36 images
OPTIONS:
========
Shadows: 0
Shadow Res: 0
UIScale: 90
Fullscreen: 1
FullscreenWindow: 1
Bloom: 0
Dynamic Batching: 0
SSAO: 0
MSAA: 0
SMAA: 0
VSync: 0
Language: 0
Shader quality: 0
========
STEAM: User stats received
Achievement 'BannedCheater' status: FALSE
Achievement 'CreateAClass' status: FALSE
Achievement 'CreateAMonster' status: FALSE
Achievement 'Ding' status: FALSE
Achievement 'First' status: FALSE
Achievement 'FiveOhOh' status: FALSE
Achievement 'FiveThousandOnline' status: FALSE
Achievement 'HundredQuests' status: FALSE
Achievement 'MaxLevel' status: FALSE
Achievement 'PaidStarterLoan' status: FALSE
Achievement 'PlayerDefeater' status: FALSE
Achievement 'TenThousandSubscribers' status: FALSE
Achievement 'TestAchievement' status: FALSE
Achievement 'YayCapitalism' status: FALSE
set mode: 0
Creating mmoDesktop
Unable to find icon for Heart of Worlds
Set name: Titan of Legends
set mode: 1
Set icon: desktop/gameicons/dentistreq.png
Set game type: Player vs Player
Set game type: Story
Destroying mmoDesktop
CreatingInitTask
set mode: 2
Icon Set 'Topic_Normal': Found 241 images
Icon Set 'Topic_Toxic': Found 5 images
Icon Set 'Reaction_Happy': Found 16 images
Icon Set 'Reaction_Sad': Found 24 images
Icon Set 'Reaction_Toxic': Found 4 images
Loading particle system: particles/fireball.vrt
Loading particle system: particles/banner.vrt
Loading particle system: particles/potionbubble.vrt
Loading particle system: particles/stun.vrt
Loading particle system: particles/slow.vrt
Loading particle system: particles/protect.vrt
Loading particle system: particles/weaken.vrt
Loading particle system: particles/buildingsparkle.vrt
!! MMO title: 'Titan of Legends'
Unable to find requested power "@ColorPicker"
Unable to find requested power "@Dungeons"
Unable to find requested power "@Build Scenery"
Unable to find requested power "@Add Quest"
Unable to find requested power "@Remove Quest"
Loading 'scenery/bamboo' models
Loading 'scenery/cactus' models
Loading 'scenery/cactus_spiked' models
Loading 'scenery/cart' models
Loading 'scenery/chair' models
Loading 'scenery/crystal' models
Loading 'scenery/mushroom_giant' models
Loading 'scenery/plant_medium' models
Loading 'scenery/plant_small' models
Loading 'scenery/post' models
Loading 'scenery/prop' models
Loading 'scenery/reed' models
Loading 'scenery/sandstone' models
Loading 'scenery/shelf' models
Loading 'scenery/spike' models
Loading 'scenery/stone' models
Loading 'scenery/table' models
Loading 'scenery/tower' models
Loading 'scenery/tree' models
Loading 'scenery/tree_dead' models
Loading 'scenery/tree_jungle' models
Loading 'scenery/tree_palm' models
Loading 'scenery/tree_pine' models
Loading 'scenery/tree_snow' models
Loading 'scenery/tree_swamp' models
Loading 'scenery/warfare' models
Loading 'scenery/water' models
Building Grid and Regions...
Smooshing enabled!
Building overall map boundaries: 16384.000000x16384.000000
Building Grid Dots: 484
Actually Built Grid Dots: 484
Building Cells
Smooshing begins!
101 smoosh operations
Smoosh completed in 363 operations!
Smooshing complete!
Regions set!
Assigning cells to regions!
Filling water regions!
Building river!
River done!
Setting region tints
Updating bounds group
Building land polyshape!
Begin region validation
Completed region validation
Making water geometry
Starting to finish regions
(0.000000): Starting to finish region 0
Converting from old data to new data
Waiting on GL fence timed out after 5 seconds. Resuming wait...
Waiting on GL fence timed out after 10 seconds. Resuming wait...
Waiting on GL fence timed out after 15 seconds. Resuming wait...
Waiting on GL fence timed out after 20 seconds. Resuming wait...
Waiting on GL fence timed out after 25 seconds. Resuming wait...
Waiting on GL fence timed out after 30 seconds. Resuming wait...
Waiting on GL fence timed out after 35 seconds. Resuming wait...
Waiting on GL fence timed out after 40 seconds. Resuming wait...
Waiting on GL fence timed out after 45 seconds. Resuming wait...
Waiting on GL fence timed out after 50 seconds. Resuming wait...
Waiting on GL fence timed out after 55 seconds. Resuming wait...
Waiting on GL fence timed out after 60 seconds. Resuming wait...
Waiting on GL fence timed out after 65 seconds. Resuming wait...
Waiting on GL fence timed out after 70 seconds. Resuming wait...
Waiting on GL fence timed out after 75 seconds. Resuming wait...
SizeChanged EVENT: 1366, 768
Minimized
Waiting on GL fence timed out after 80 seconds. Resuming wait...
Waiting on GL fence timed out after 85 seconds. Resuming wait...```

We’ve already spoken about this over on Discord, but just to repeat that information here:

From the log, it looks like you’re running really old video drivers on an old graphics chipset. I’d recommend that you update your video drivers, and that might fix up this issue for you?

(You seem to be running an Intel HD Graphics 4000 chipset, using driver version 10.18.10.4425, while the most recent version of the driver listed on Intel’s site is 15.33.53.5161.)

1 Like

Thanks Trevor, I did not see the discord message yet. I will try to update the driver. Yesterday I downloaded the auto updater for intel and it said it was up to date but it must’ve been an human error. I will see if it runs after I update. If it doesn’t, to bad and I’d have to wait till I can get a better Pc. Thanks for your time anyway.