Game lags and second monitor flickers

When I start the Game, my second monitor directly starts flickering and the game has a Framerate of 2 Fps or so. Not playable. I updated the game today: v0.17.36
My Specs are Win10, Intel Core i5-7500, 8Gb RAM, Nvidia GTX1060.

And I guess this is important?
MMORPG Tycoon 2
win64
0.17.38-g46ce649
Checking supported resolutions…
Available Modes
0: 1920 x 1080
1: 1768 x 992
2: 1680 x 1050
3: 1600 x 1024
4: 1600 x 900
5: 1440 x 900
6: 1366 x 768
7: 1360 x 768
8: 1280 x 1024
9: 1280 x 960
10: 1280 x 800
11: 1280 x 768
12: 1280 x 720
13: 1176 x 664
14: 1152 x 864
15: 1024 x 768
16: 800 x 600
17: 720 x 576
18: 720 x 480
19: 640 x 480
Init: Initialising fullscreen window
Width before: 1024
Found 2 displays:
Display #0 Generic PnP Monitor (1920x1080)
Display #1 Generic PnP Monitor (1680x1050)
SDL_CreateWindow 1024x768x32 video mode, flags 4099
OpenGL Context:
Vendor: NVIDIA Corporation
Renderer: GeForce GTX 1060 6GB/PCIe/SSE2
Version: 3.3.0 NVIDIA 432.00
GLEW: 1.11.0
Shading Language Version: 3.30 NVIDIA via Cg compiler
== Begin OpenGL limits ==
== End OpenGL limits ==
VSync: ENABLED
TextureUnits: 32 from vertex shader, 192 total
Width after: 1920
Screen Ratio: 1.777778
CPU: Intel® Core™ i5-7500 CPU @ 3.40GHz
Number of hardware cores: 4
– Initialising game “MMORPG”
TextInput was enabled by default; turning it off until we need it!
SDL window resize event showing window size as 1920x1080, SDL_GetWindowSize() shows size as 1920x1080
Screen aspect ratio: 1.777778
STEAM: UserId: 76561198097122426
STEAM: Username: BenGMAN
STEAM: Branch: default
Found 36 desktop game icon images
Requested language: english
STEAM: User stats received

Frames rendered: 366

Average FPS: 56.700233

Frames missed: 0

mmoWindow::Shutdown
– Deinitialising game “MMORPG”
– Exitting game “MMORPG”

FIFO High water mark: 5898 of 4096000 (0.14% usage)

And thank you very much for that great game.

Everything looks okay, and you ought to be able to play the game just fine with that hardware. Out of curiosity, can you try running the game in windowed mode and see if it makes a difference? Just hit alt-enter to swap into windowed mode.

It might also be interesting to try without your second monitor connected, just to see whether that makes any difference. (it shouldn’t, but… trying to think of anything that might be making your computer different from other ones, that could result in the game running so slowly right from the start!)