Failed assertion: Unable to link shaders


#1

Issue: Failed assertion game crash
Crash (y/n): Y
Platform (Windows/Mac/Linux): Windows 10
Description: On creation of new mmo failed assertion pops up during map creation.

Unable to link shaders

see image for error message. Log submitted via in game solution.Capture


#2

Whoah, that’s a new one! Does that happen every time for you? I can’t seem to make it happen on any platform. Is it only when creating a new mmo, not when loading a saved one?


#3

Happened every time I have created a new mmo so far also seems to occur on previous saves.
This is on my AMD PC not tried on the intel/nvidia laptop yet


#4

Tried the new build and still haveing the same issue uploaded the logs via the ingame


#5

Thanks heaps for reporting! These extra logs are giving a bunch of useful new data!


#6

Okay. So it looks like one of the shader files is completely empty for you, which is weird.

Can you check inside the game files to verify that the file is intact? The place to look is inside the game directory, at:

Data/MMORPG/shaders/line_f.glsl

(It’s just a standard text file).

There should be around 70 lines in that file, but for some reason, the game has loaded zero lines from it, for you. Now, it might be a bug in my code which has broken things, or you might actually have a broken file somehow that Steam hasn’t noticed (in which case you’d want to Verify Integrity of the game files, in the game properties in Steam, to restore the file contents)


#7

after checking the file and finding that nothing was contained in it. after doing a file verification via steam as suggested 3 items were found as issues and re-downloaded by steam.

The game once again works.

I had previously used the built in option through steam to move the game to a different hard drive I do wonder if that process caused the corruption in the first place.


#8

Awesome news; thanks for letting me know, @yxxxx2003! Verify Files becomes a new go-to piece of advice for folks who are having troubles! I should put that into the crash reporter, too.