CTD: log file error

Issue: Game immediately crashes upon opening, with a Failed Assertion
Crash (y/n): Y
Platform (Windows/Mac/Linux): Windows 7
Version number: Can’t reach main menu, but it was immediately after the Creativity Spike: Walls update
Description: Game immediately crashes upon opening, with the error: “Failed Assertion: Error opening file crashreports/log.txt: permission denied. Failed condition (m_file != NULL) at VS_File.cpp:302”

I’ve checked AppData\Roaming\VectorStorm\MMORPG Tycoon 2\crashreports and there’s no log file present. I tried creating a “dummy” log.txt, but that didn’t help.

I’ve done a full uninstall and reinstall and the problem persists.

Link to most recent crash.rpt: Dropbox - crash.rpt - Simplify your life

Weird!

The game will look for crashreports/log.txt file in the following places:

  1. Inside %AppData%\Roaming\VectorStorm\MMORPG Tycoon 2\
  2. Inside the install directory for MT2 (which should be inside SteamApps\Common\MMORPG Tycoon 2 in your Steam Library directory.)
  3. Inside the ‘Data’ directory inside the directory from 2.
  4. Inside the ‘Default.zip’ or ‘MMORPG.zip’ files inside the directory from 3. (these would have been fixed by an uninstall/reinstall, if the files had somehow gotten in here. The game can’t write into these files itself, but I guess the user could?)
  5. If there is a ‘mod’ directory inside the directory from 1, it could load it from in there?

I’m not sure where else to look to find that log.txt file. After doing a full uninstall, can you verify that there are no files left in your steam library’s steamapps/common/MMORPG Tycoon 2/ folder (or ideally, the folder is removed entirely?)

Might be worth also checking the drive for errors, which you can do by right-clicking on the drive icon, choosing ‘Properties’, and then clicking on the ‘Error checking: Check’ button on the ‘Tools’ tab. That’ll let you safely scan the drive to make sure there aren’t any problems.

It gets weirder! After poking at it for a little bit, I tried explicitly running the MT2.exe as an administrator, and it seemed to work. I’m not sure why, as I’m playing on an administrator account already, and I don’t know how the problem popped up out of the blue, but at least it’s fixed now!

Thanks for the help, and I’ll let you know if I find a way to reproduce it.

Returning to this in case anyone else was having a similar issue - I recently realised this was probably down to my antivirus software (Avast) being a little too zealous.

It also prevented some updates downloading/installing correctly (with Steam giving a “disk write error” message as a result).

Temporarily disabling the anti-virus and adding an exception seemed to fix it!

1 Like