Crashing at starting

i just downloaded the game today… and it keep crashing at laun, music of startig can be heard for 1 sec (no ui or game seen exept the icon) and then it close. no error message

What OS are you running, and what are your system specs?

Once I know your OS, I’ll tell you where to find your log files, which may be able to tell us what’s not working for you!

i9-9900k
16gb ram
nvidia 1070
windows 10

That should be plenty to run the game (it’s better than my main development PC!)

Okay, find the game log here:

C:\Users\<AccountName>\AppData\Roaming\VectorStorm\MMORPG Tycoon 2\log.txt

Note that the ‘AppData’ folder might be automatically hidden by Windows. If so, you might need to type that part into the address bar, rather than click on an icon to get into the folder.

Anyhow, if you can post that log file then hopefully it’ll have some useful information about what’s gone wrong! You can either post it here or send it to me as a private message. :slight_smile:

MMORPG Tycoon 2
win64
0.17.29-gdddade9
Checking supported resolutions…
Available Modes
0: 1680 x 1050
1: 1600 x 1024
2: 1600 x 900
3: 1440 x 900
4: 1366 x 768
5: 1360 x 768
6: 1280 x 1024
7: 1280 x 960
8: 1280 x 800
9: 1280 x 768
10: 1280 x 720
11: 1152 x 864
12: 1024 x 768
13: 800 x 600
14: 720 x 576
15: 720 x 480
16: 640 x 480
Init: Initialising fullscreen window
Width before: 1024
Found 2 displays:
Display #0 SyncMaster T220/T220G,SyncMaster Magic T220/T220G(Digital) (1680x1050)
Display #1 Philips 220BW (22inch Wide LCD MONITOR 220BW8) (1680x1050)
SDL_CreateWindow 1024x768x32 video mode, flags 4099
OpenGL Context:
Vendor: NVIDIA Corporation
Renderer: GeForce GTX 1070/PCIe/SSE2
Version: 3.3.0 NVIDIA 441.41
GLEW: 1.11.0
Shading Language Version: 3.30 NVIDIA via Cg compiler
== Begin OpenGL limits ==
== End OpenGL limits ==
VSync: ENABLED
TextureUnits: 32 from vertex shader, 192 total
Width after: 1680
Screen Ratio: 1.600000
CPU: Intel® Core™ i9-9900K CPU @ 3.60GHz
Number of hardware cores: 16
– Initialising game “MMORPG”
TextInput was enabled by default; turning it off until we need it!
SDL window resize event showing window size as 1680x1050, SDL_GetWindowSize() shows size as 1680x1050
Screen aspect ratio: 1.600000
STEAM: UserId: 76561198018464737
STEAM: Username: LordLucifer-
Found 36 desktop game icon images
STEAM: User stats received
Found crash report; archiving it.

Okay, from the log it looks like the game is hitting a crash, and it’s happening before the crash reporter can handle it.

Inside the same directory that held the log.txt file, there should be a text file: “crashreports/crash.rpt”. Can you show the contents of that file? (If it’s empty or missing, which based upon where this problem is occurring I’m guessing it might be, there’d be another copy of it inside the game’s steam installation directory (“Browse Local Files” button within the game properties in Steam, to get there), saved in there as “MT2.RPT”; if you can’t get at crash.rpt, give me the MT2.RPT file instead. :smiley:

This should give us our best bet at catching whatever the problem is!


Error occurred on Tuesday, January 21, 2020 at 14:49:47.

MT2.exe caused an Access Violation at location 00007FFDCD250B0A DEP violation at location 00007FFDCD250B0A.

AddrPC Params
00007FFDCD250B0A 0000000000000000 000000006C83769F 00007FFECFE46A10
00007FFECDFD4A8E 0000015ADDBDF858 00007FFE77050000 0000015ADDBBDD30 gdi32full.dll!SwapBuffers
000000006C825A55 0000015ADDBC6380 0000000000000001 0000015AD8F2B100 SDL2.dll!SDL_DYNAPI_entry
000000000059689B 0000000044E6F0AF 0000000000000000 000000003F800000 MT2.exe!vsRenderer_OpenGL3::PostRender
00000000005A0198 0000000000000000 0000000000000000 0000000000000000 MT2.exe!vsScreen::DrawPipeline
000000000034994C 000000192A3FF990 0000015ADB8C8380 0000015ADDBC6380 MT2.exe!mmoGame::DrawFrame
000000000054C4A5 00000000656D6167 0032206E6F6F6379 000000192A3FF9B0 MT2.exe!coreGame::Go
000000000054BBD7 000000192A3FF980 0000000000B5CF40 000000192A3FF980 MT2.exe!core::Go
0000000000141874 0000000000000000 000000000000003F 0000000000CF24E8 MT2.exe!SDL_main
00000000001413C7 0000000000E42310 000000192A0E7000 0000000000000000 MT2.exe!__tmainCRTStartup [./build/x86_64-w64-mingw32-x86_64-w64-mingw32-crt/./mingw-w64-crt/crt/crtexe.c @ 339]
00000000001414CB 0000000000000000 0000000000000000 0000000000000000 MT2.exe!WinMainCRTStartup [./build/x86_64-w64-mingw32-x86_64-w64-mingw32-crt/./mingw-w64-crt/crt/crtexe.c @ 195]
00007FFECFE47BD4 0000000000000000 0000000000000000 0000000000000000 KERNEL32.DLL!BaseThreadInitThunk
00007FFED02ACED1 0000000000000000 0000000000000000 0000000000000000 ntdll.dll!RtlUserThreadStart

MT2.exe
ntdll.dll 6.2.18362.418
aswhook.dll 19.8.4793.0
KERNEL32.DLL 6.2.18362.329
KERNELBASE.dll 6.2.18362.535
msvcrt.dll 7.0.18362.1
SHELL32.dll 6.2.18362.535
ucrtbase.dll 6.2.18362.387
cfgmgr32.dll 6.2.18362.387
shcore.dll 6.2.18362.1
RPCRT4.dll 6.2.18362.476
combase.dll 6.2.18362.449
bcryptPrimitives.dll 6.2.18362.295
windows.storage.dll 6.2.18362.535
msvcp_win.dll 6.2.18362.387
sechost.dll 6.2.18362.267
advapi32.dll 6.2.18362.329
profapi.dll 6.2.18362.1
powrprof.dll 6.2.18362.1
UMPDC.dll
shlwapi.dll 6.2.18362.1
GDI32.dll 6.2.18362.1
win32u.dll 6.2.18362.592
gdi32full.dll 6.2.18362.535
USER32.dll 6.2.18362.592
kernel.appcore.dll 6.2.18362.1
cryptsp.dll 6.2.18362.1
libcurl-4.dll
WLDAP32.dll 6.2.18362.449
WS2_32.dll 6.2.18362.387
dbghelp.dll 6.3.9600.17298
OPENGL32.dll 6.2.18362.387
WSOCK32.dll 6.2.18362.1
zlib1.dll 1.2.11.0
exchndl.dll 0.8.1.0
PSAPI.DLL 6.2.18362.1
libphysfs.dll
SDL2_image.dll 2.0.4.0
SDL2.dll 2.0.9.0
IMM32.dll 6.2.18362.387
ole32.dll 6.2.18362.113
OLEAUT32.dll 6.2.18362.535
SETUPAPI.dll 6.2.18362.1
bcrypt.dll 6.2.18362.267
steam_api64.dll 3.42.61.66
fmodstudio64.dll 0.1.8.4
GLU32.dll 6.2.18362.387
mgwhelp.dll 0.8.1.0
VERSION.dll 6.2.18362.1
WINMM.dll 6.2.18362.1
fmod64.dll 0.1.8.4
WINMMBASE.dll 6.2.18362.1
MSACM32.dll 6.2.18362.1
dxcore.dll 6.2.18362.1
gameoverlayrenderer64.dll 5.61.49.46
steamclient64.dll 5.61.49.46
CRYPT32.dll 6.2.18362.592
MSASN1.dll 6.2.18362.1
imagehlp.dll 6.2.18362.1
IPHLPAPI.DLL 6.2.18362.1
tier0_s64.dll 5.61.49.46
vstdlib_s64.dll 5.61.49.46
MSWSOCK.dll 6.2.18362.1
Secur32.dll 6.2.18362.1
SSPICLI.DLL 6.2.18362.1
CRYPTBASE.DLL 6.2.18362.1
uxtheme.dll 6.2.18362.449
libjpeg-9.dll
libpng16-16.dll
XSplitGameSource64.dll 1.1.1906.1001
clbcatq.dll 2001.12.10941.16384
dinput8.dll 6.2.18362.1
inputhost.dll 6.2.18362.387
CoreMessaging.dll 6.2.18362.1
CoreUIComponents.dll 6.2.18362.207
PROPSYS.dll 7.0.18362.267
wintypes.dll 6.2.18362.449
ntmarta.dll 6.2.18362.1
HID.DLL 6.2.18362.1
DEVOBJ.dll 6.2.18362.387
WINTRUST.dll 6.2.18362.387
XInput1_4.dll 6.2.18362.329
MSCTF.dll 6.2.18362.535
nvoglv64.dll 26.21.14.4141
WTSAPI32.dll 6.2.18362.1
dwmapi.dll 6.2.18362.267
nvspcap64.dll 3.20.1.57
WINSTA.dll 6.2.18362.53
TextInputFramework.dll 6.2.18362.267
iertutil.dll 11.0.18362.449
MMDevApi.dll 6.2.18362.387
wdmaud.drv 6.2.18362.1
ksuser.dll 6.2.18362.1
AVRT.dll 6.2.18362.1
AUDIOSES.DLL 6.2.18362.449
msacm32.drv 6.2.18362.1
midimap.dll 6.2.18362.1
resourcepolicyclient.dll 6.2.18362.1
GameMode.dll 6.2.18362.1
WININET.dll 11.0.18362.418
ondemandconnroutehelper.dll 6.2.18362.1
winhttp.dll 6.2.18362.449
NSI.dll 6.2.18362.449
WINNSI.DLL 6.2.18362.449
urlmon.dll 11.0.18362.449
DNSAPI.dll 6.2.18362.267
mdnsNSP.dll 3.1.0.1
rasadhlp.dll 6.2.18362.1
fwpuclnt.dll 6.2.18362.207

Windows 6.2.9200
DrMingw 0.8.1

Thanks for posting that! Based on that crash report, it looks like it’s crashing inside your graphics driver. Is your driver relatively up to date?

Also, worth testing our ‘test’ branch on Steam, which has one rendering related fix in it which has helped a couple folks (although mostly Mac users)… I don’t especially expect that to fix this issue, but it’s worth trying just in case!

my graphic driver is up to date and still crashing

same problem with test

Hm… anything unusual about your video setup? Like… I dunno. Multiple monitors? Weird refresh rates on the monitors? Are you on a laptop with an external screen attached? None of those should be problems, but… clearly something is going wrong, and the crash log isn’t giving me enough information to guess what that something is… so… just trying to figure out what might be different about your setup than other people, which is leading to this crash.

i have 2 monitors , tried to unplug 1 didnt change anything so ig ot no idea , its the first game that happen to me

Oh! Something to try:

Try going into that same directory again and editing the vectorstorm.prefs file and find these lines:

Fullscreen 1
FullscreenWindow 1

Change them to:

Fullscreen 0
FullscreenWindow 0

That’ll switch the game to open in a regular window instead of trying to go fullscreen. You can also change the WindowResolutionX and WindowResolutionY lines, if you like, to specify the size you want the window to be (though you can resize it later, while the game is running). I wonder if it’ll be happier running in a window than in a fullscreen mode.

in the appdata roaming folder of the game?

Yes, in that same directory; AppData/Roaming/VectorStorm/MMORPG Tycoon 2/

well there is a problem Capture

lol, okay, right, it’s crashed before it has written out the preferences file! Hold on and I’ll send you one.

@trevor ! good and bad news ! the problem come froms steam download look like something going bad when (players like me download the files) I downloaded a crack and had directly no problem launching it. tried to had some files from the crack to steam version . nothing worked still so something from steam is making it go wrong (yes Imade another account cause I had 11 hours wait x)

Good to know! Will have a bit more of a think about things!

still sck I need to use a crack atm xD but yhea hope it can help you find whats going on